make include/linux/version.h fails due to missing .config file

Richard Betel emteeoh at
Tue Jan 18 13:20:57 PST 2005

On Tue, 18 Jan 2005 16:11:18 -0500, Wolcott, Kenneth
<ken.wolcott at> wrote:
> Hi;
>   I made it to page 49 (pdf) of LFS 6.0 (section 5.7.1) where I run into
> problems with the "make include/linux/version.h" step.  The error message is
> as follows: "Makefile: 415: .config: No such file or directory".
>   Perhaps I've made errors prior to this and it has caught up to me :-(

If you just unpack the linux tarball, you won't get a .config, and
"make mrproper" definitely deletes .config. You have 2 options to get
a .config:

1) copy it from a different kernel build directory, possibly from a
different machine of the *SAME* architecture
2) make it. I use "make menuconfig" but you can of course do an x
config, or  whatever...

Are you building on an intel? I ran into this problem on a DEC Alpha
and assumed it was an idiosyncracy of my platform. Now I'm wondering
if its a failing of the current LFS book.

More information about the lfs-support mailing list