[HELP] lfs 6.0 mkfs can't find device

Chun Hui chui at kml.com.hk
Mon Jan 17 17:16:10 PST 2005

Thanks Tobias, I have tried udevstart and even restart the computer, but 
still same result.  How can i check whether the udev have detected my new 
partition or not? Any idea?

Chun Hui
Analyst Programmer
KML Engineering Limited [www.kml.com.hk]
Tel: 852-2929-5658    Fax: 852-2635-6181
chui at kml.com.hk

This e-mail is intended for the addressee(s) only.  It is privileged and may 
also be confidential.  Any review, retransmission, or other use of this 
information by persons other than the addressee is prohibited.  If you are 
not the intended recipient, please notify the sender immediately and delete 
the material from all your computer.
"Tobias Gasser" <tg at ebp-gasser.ch> wrote in message 
news:csg8pp$ku5$1 at belgarath.linuxfromscratch.org...
>> -bash-3.00# mkfs /dev/hdd1
>> mke2fs 1.35 (28-Feb-2004)
>> mkfs.ext2: No such file or directory while trying to determine hardware 
>> sector size
>> -bash-3.00#
>> I have checked the /proc/ide/, /sys/block/, and /dev/, the device seems 
>> detected by the system coz the file folder ide1, hdd, and hdd are in the 
>> corresponding place.  I also try to add a 2nd harddisk in ide0 and i can 
>> do the mkfs to the new harddisk.  So, is it the problem with the udev and 
>> the CF device?
> jep!
> udev doesn't get notified after fdisk has added or deleted partitions. 
> just let 'udevstart' gather the new partitions you created. i noticed this 
> behaviour even on hda when adding a new partition!
> maybe ejecting the cf and reinserting will help as hotplug should trigger 
> udev to re-read the cf-card partition table.
> tobias 

More information about the lfs-support mailing list