LFS 6.0 kernel 2.6.8.1 -> 2.6.10 ?

Jeremy Utley jeremy at jutley.org
Fri Jan 14 11:47:13 PST 2005


Matthew Burgess wrote:

> Jeremy Utley wrote:
>
>> GCC, and binutils, for the most part, can be upgraded on the machine 
>> safely.
>
>
> Just a word of warning - upgrading between major versions of gcc is 
> not recommended - e.g. from gcc-3.x to gcc-4.x, due to changes in 
> library versions.  I think that library versions (e.g. libstdc++) can 
> change between major.minor releases as well, but not between 
> major.minor.patch releases.
>
> Regards,
>
> Matt.

Except, with GCC, when a library becomes incompatible, it's named 
differently, i.e. libstdc++-libc6* vs. libstdc++.so.3, meaning that the 
old library would still be present for applications compiled with the 
old compiler and needing it.

-J-



More information about the lfs-support mailing list