LFS 6.0 kernel 2.6.8.1 -> 2.6.10 ?

Steve Crosby fost at hotmail.com
Thu Jan 13 00:56:02 PST 2005


roger21 <roger21 at free.fr> wrote in news:41E605A2.80701 at free.fr:

> Nathan Coulson a écrit :
>> On Thu, 13 Jan 2005 05:18:07 +0100, Benoît VILA <bvila at free.fr> wrote:
>> 
>>>hi,
>>>
>>>if i want to update my kernel, is it enough to install the new
>>>linux-libc-header package and the new kernel package? what should be
>>>re-compiled (except the kernel of course)?
>>>
>>>thanks
>> 
>> 
>> You should never replace your linux-libc-headers package on your
>> system.  Simple compile a new kernel, and overwrite /boot/lfskernel
>> and /boot/System.map [filenames may vary, please consult the book you
>> used]
>> 
> 
> 
> oh .. ok but isn't it to disturbing to have different linux-headers from 
> the linux kernel ?
> 

no - the linux-libc-headers are (as the name suggests) headers for use by 
libc (and other apps) not the kernel. When a new package is built that 
references the linux-libc-headers, it must use the same version as that 
used to build libc, so the ABI stays the same.

-- -
Steve Crosby



More information about the lfs-support mailing list