Building LFS book 6.0 on Alpha

Richard Betel emteeoh at
Thu Jan 13 17:14:06 PST 2005

I'm having some trouble building book 6 on Alpha. I could use some help
First, the issues I have solved/worked-around

1) glibc seems to need linux/autoconf.h which is made when you build
the linux kernel. OK, so I created a .config and ran make
include/linux/autoconf.h and then after that glibc builds
2) the strip binaries step in chapter 5 fails under nALFS 1.2.4. Not a
big deal, I just don't do that step. (just an FYI, I'm using the ALFS
book 6.0-1 profile)

Then I move on to chapter 6. It starts OK, but I have two problems there so far:
1) glibc tests fail. It looks like a precision error in atan2 inline,
so I ignored it, but hey! Its happening. glibc builds cleanly though.
2) binutils also fails make check. It appears to be errors in the
linker. I get the following errors:
FAIL: TLS -fpic -shared
FAIL: TLS -fpic and -fno-pic exec
FAIL: TLS -fpic and -fno-pic exec relax
FAIL: visibility (hidden_weak)
FAIL: visibility (hidden_weak) (PIC main)
FAIL: visibility (protected_weak)
FAIL: visibility (protected_weak) (PIC main)
FAIL: ELF DSO weak func first DSO
FAIL: ELF DSO weak func last DSO
FAIL: ELF weak func first DSO
FAIL: ELF weak func last DSO

I also get 2 warnings at the start:
warning: couldn't find the global config file
warning: couldn't find tool init file

Any ideas on what/where I have gone wrong would be most appreciated.

More information about the lfs-support mailing list