can't find /dev/hda* when booting

Salman Javed salmanz100 at
Tue Jan 11 21:36:35 PST 2005

Hi, I've just done a LFS 6.0 stable installation. There were no apparent 
errors. However, when I reboot and start the LFS system, it doesn't find my 
swap and home partitions!

swapon: cannot stat /dev/hda2 : no such file or directory
mount: special device /dev/hda3 does not exist
Setting lfs as hostname                        <hangs here>

My partitioning scheme:
hda1 vfat /windows
hda2 swap swap
hda3 reiserfs /home
hda5 reiserfs /suse (my host)
hda6 reiserfs /

My fstab:
/dev/hda6     /            reiserfs  defaults        0     0
/dev/hda2     swap     swap      pri=42          0     0
/dev/hda3     /home        reiserfs  defaults        0     0
proc          /proc        proc      defaults        0     0
sysfs         /sys         sysfs     defaults        0     0
devpts        /dev/pts     devpts    gid=4,mode=620  0     0
shm           /dev/shm     tmpfs     defaults        0     0

My SUSE fstab, which works in SUSE:
/dev/hda5            /                    reiserfs   acl,user_xattr        0 
/dev/hda6            /mnt/lfs               auto     defaults              0 
/dev/hda3            /home                reiserfs   acl,user_xattr        0 
/dev/hda1            /windows/C           vfat       
users,gid=users,umask=0002 0 0
/dev/hda2            swap                 swap       pri=42                0 
devpts               /dev/pts             devpts     mode=0620,gid=5       0 
proc                 /proc                proc       defaults              0 
usbfs                /proc/bus/usb        usbfs      noauto                0 
sysfs                /sys                 sysfs      noauto                0 
/dev/cdrecorder      /media/samsungcdr    subfs      
user,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/cdrecorder11     /media/hpdvd         subfs      
fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

kernel (hd0,5)/boot/lfskernel root=/dev/hda6

So I logged back into SUSE, chrooted and looked in LFS's /dev folder. There 
was nothing except for /dev/null and /dev/console. So I mknod'ed hda1-6. 
Mounting under the chrooted environment works fine now and is automatic.

However, it still doesn't work under the real LFS system.

I've tried the option devfs=nomount and it does nothing. I don't remember 
enabling devfs in the kernel. I certainly do have udev programs installed. 
My IDE drivers are not modules, and I made sure to compile the reiserfs 
drivers into the kernel (not as modules). What could I be doing wrong?

Where exactly in the kernel make menuconfig is the devfs/udev enable/disable 
option? I might not have disabled devfs properly. However, I don't seem to 
have  /dev/tty/ et al on the / partition and wonder if devfs is actually the 
problem here.

Also, LFS *does* detect my / (/dev/hda6) partition automatically. The 
terminal spits out the normal messages: that the system found reiserfs 
format "3.6" with standard journal, using ordered data mode, etc. But it 
does not detect my /home partition, which is also reiser.

Help appreciated.

Need more speed? Get Xtra JetStream  @

More information about the lfs-support mailing list