gcc linkonce & pwlib

Jim Gifford lfs at jg555.com
Mon Jan 10 10:53:13 PST 2005

Laurens Blankers wrote:

>Hello list,
>I may have a problem with the gcc linkone patch. When compiling pwlib
>(http://www.openh323.org/) I get the following error:
>make[3]: Entering directory `/mnt/superbig/home/laurensb/pwlib/tools/asnparser'
>g++ -o obj_linux_x86_d/asnparser -O2 -march=pentium2 -pipe
>-I/usr/db42/include -L/usr/db42/lib -L/usr/db42/lib -Wl,--gc-sections
>-s -L/home/laurensb/pwlib/lib -L/usr/db42/lib -Wl,--gc-sections 
>-L/home/laurensb/pwlib/lib -L/usr/db42/lib -Wl,--gc-sections 
>-L/home/laurensb/pwlib/lib -L/usr/db42/lib -Wl,--gc-sections 
>-L/home/laurensb/pwlib/lib   ./obj_linux_x86_d/asn_grammar.o 
>./obj_linux_x86_d/asn_lex.o  ./obj_linux_x86_d/main.o -lpt_linux_x86_d
>-lpthread -lssl -lcrypto -lexpat -lSDL -lresolv -ldl
>/usr/bin/ld: ./obj_linux_x86_d/asn_grammar.o(.gnu.linkonce.r._ZTV10PBaseArrayIcE+0x1c):
>unresolvable relocation against symbol
>`PAbstractArray::Compare(PObject const&) const'
>/usr/bin/ld: final link failed: Nonrepresentable section on output
>collect2: ld returned 1 exit status
>make[3]: *** [obj_linux_x86_d/asnparser] Error 1
>I was about to post something to the openh323 mailinglist when I
>noticed the ".gnu.linkonce.r." in the error message.
>Could this be a problem with the linkonce patch?
>I am running LFS 6.0, but have recently upgraded gcc to 3.4.3
>according to LFS unstable SVN-20050109.
It seems to be a bison issue, from what I found when I tried to build on 
the current SVN version with bison-2.0, I get this error message.

make[3]: Leaving directory `/usr/src/pwlib/tools/asnparser'
set -e; make -C src/ptlib/unix debug; make -C tools/asnparser debug;
make[3]: Entering directory `/usr/src/pwlib/src/ptlib/unix'
/usr/src/pwlib/lib/obj_linux_x86_d/asner.dep:1: *** missing separator.  
make[3]: Leaving directory `/usr/src/pwlib/src/ptlib/unix'
make[2]: *** [debug] Error 2
make[2]: Leaving directory `/usr/src/pwlib'
make[1]: *** [libs] Error 2
make[1]: Leaving directory `/usr/src/pwlib'
make: *** [debuglibs] Error 2

When I tried with bison 1.875d, I got the same error message as you.

jim at linuxfromscratch.org
lfs at jg555.com

LFS User # 2577
Registered Linux User # 299986

FWD: 275410
IPKall: 360-968-1517

More information about the lfs-support mailing list