../../binutils-2.15.90.0.1.1/binutils/../ylwrap: line 86: -d: command not found (in chapter 6 of LFS-5.1.1)

MadMac asd11 at wp.pl
Sat Jan 8 03:50:42 PST 2005


On Sat, 8 Jan 2005 16:58:21 +0530, Mukesh Kaushal <mkaushal1980 at gmail.com>  
wrote:

> Hello
> I'm building lfs-5.1.1 using FedoraCore 1(Kernel 2.4.22) on a PIII
> machine. I'm using binutils-2.15.90.0.1.1 and got an error in chapter
> 6. The snapshot of the problem is given below:
>
> ---------------------------------------------------------------------------------------------------------------------------------
> ./libiberty/libiberty.a  -ldl
> gcc -W -Wall -Wstrict-prototypes -Wmissing-prototypes -g -O2 -o
> .libs/objdump objdump.o budemang.o prdbg.o rddbg.o debug.o stabs.o
> ieee.o rdcoff.o bucomm.o version.o filemode.o
> ../opcodes/.libs/libopcodes.so ../bfd/.libs/libbfd.so
> -L/sources/binutils-build/libiberty/pic -liberty
> ../libiberty/libiberty.a -ldl
> bucomm.o(.text+0xa99): In function `make_tempname':
> ../../binutils-2.15.90.0.1.1/binutils/bucomm.c:425: warning: the use
> of `mktemp' is dangerous, better use `mkstemp'
> creating objdump
> /bin/sh ../../binutils-2.15.90.0.1.1/binutils/../ylwrap ""
> ../../binutils-2.15.90.0.1.1/binutils/arparse.y y.tab.c arparse.c
> y.tab.h arparse.h --  -d
> ../../binutils-2.15.90.0.1.1/binutils/../ylwrap: line 86: -d: command  
> not found
> make[3]: *** [arparse.c] Error 1
> make[3]: Leaving directory `/sources/binutils-build/binutils'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/sources/binutils-build/binutils'
> make[1]: *** [all-recursive-am] Error 2
> make[1]: Leaving directory `/sources/binutils-build/binutils'
> make: *** [all-binutils] Error 2
> root:/sources/binutils-build#
> -----------------------------------------------------------------------------------------------------------------------------------
> Plz suggest me where I went wrong.
> Thanx
> monny
Binutils 2.15.* requires flex and bison which are not installed in LFS 5.*  
chapter 5.
You can either downgrade binutils to 2.14 or install flex and bison
in /tools while You in chapter 5
-- 
MadMac - asd11 at wp.pl
Linux should be fun.



More information about the lfs-support mailing list