can anyone help me? Strangely, I can't use my user "lfs"

Megan Simpson my23mimosas at
Fri Jan 7 11:04:31 PST 2005

I am having a strange problem with my newly added user, "lfs". I don't think
this is a typical problem for my OS. I think my system is F.*[k|u|c]*.*ed 
(Hey, that pattern matches "Firetruck-mechanics," too!)  ;-)

After creating user "lfs" manually, using useradd, (on Mandrake 10.0 
(lfs has user ID=501 according to file /etc/passwd, and userdrake agrees)
I issue `su lfs' or `su - lfs' as root:

        root]# su - lfs
        could not open session

So I issue `login', the system prompts for the username, password:

        root]# login
        samadhi login: lfs
        id: cannot find name for user ID 501

I continue anyway, creating my .bash_profile and .bashrc according to
instructions in LFS 5.1.1. I then issue:

        -bash-2.05b$ source ./.bash_profile
        I have no name!:~$whoami
        whoami: cannot find username for UID 501

Note that, although I logged in with the user name "lfs" and it correctly 
logged me in as
user=#501, bash can't track userID back to user=lfs -- strange.

I followed the directions in LFS 5.1.1 explicitly for every step, including 
the useradd options.
(except that I used a partition I already had -- but I changed the mount 
point to /mnt/lfs ($LFS=/mnt/lfs in environment and fstab contains a line: 
"/dev/hdb5 /mnt/lfs ext3 defaults 1 2").

userdrake has the following information in the table's row for user lfs:

  User Name    User ID   Primary Group   Full Name    Login Shell    Home 
Directory   Status
  lfs                501        lfs                   lfs              
/bin/bash       /home/lfs

/etc/passwd contains a line:


group ID 501 belongs to another user's primary group, as does 502. AFAIK, 
there are no expected
complications for having unmatched userID and groupID.

Can anyone help me? I am thoroughly confused.

BTW, I just tried to log in as other users that I
expect to work (which worked very recently) and I get the same. If I try to 
log into any user other
than root, it fails. Even using kdm or gdm or xdm. Yes, I am online as root  
--   8^O    --
I don't seem to have any other choice, and don't seem to have a working 
system to ruin. I also have a pretty strong set of ipfilter rules, which 
hopefully will protect me somewhat until I get this fixed...


Express yourself instantly with MSN Messenger! Download today - it's FREE! 

More information about the lfs-support mailing list