LFS Install

Casey James Price linuxproject at aws-sj.com
Tue Jan 4 15:46:46 PST 2005

Hi there,
    So I've been reading through the LFS-6.0 book and following along. I'm
actually on my third try, because on the first two I screwed up a couple of
times on small things that messed up the whole build. This time I actually
got all the way through without any errors or issues, hey third time is a
charm, right? However, I counted this as a success too soon, because I get a
kernel panic when I reboot. I used Debian Sarge as my host system and as the build kernel on both the host and destination system.
Basically I have my menu.lst for grub set to:
title        LFS-6.0
root        (hd0,3)
kernel     /boot/lfskernel- root=/dev/hda4
it goes through the initial steps of booting, but then when it comes time
for VFS to mount the root fs it fails saying: "Kernel Panic: VFS cannot
mount root fs unknown on (3,4)" or something to that extent. If I try
booting up with just kernel  /boot/lfskernel- and no "root=/dev/hda4"
it fails similarly saying that I must specify a valid "root=" option. I
tried creating an initrd image from my host system by copying the
/etc/mkinitrd/mkinitrd.conf and /usr/sbin/mkinitrd file to my lfs partition,
chrooting and then running it...and that seemed to do a little bit. With
this it actually mounts the root fs as cramfs and gets a little further and
then dies with another kernel panic. This time it says something about
unable to load dev/console even though my lfs partition has /dev/console,
and then says something tried to kill init. At first I thought the whole
root= problem was something to do with the fact that my lfs partition is
ext3 and I had ext2 built into the kernel, and ext3 as a module...but then I
fixed this so both ext2 & ext3 were built in. So if someone out there could
help me out it would be really awesome.

No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.300 / Virus Database: 265.6.8 - Release Date: 1/3/2005
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20050104/0985f6ec/attachment.html>

More information about the lfs-support mailing list