Error when configure glibc

Mark Olbert mark at
Fri Jan 7 09:24:46 PST 2005

I ran into the exact same problem. I'm pretty sure it was due to an
incorrect build of gcc in chapter 5, "incorrect", as in the wrong gcc being
used at some point in the cycle.

In my case I think what caused the problem involved the PATH variable for
the build environment being set up wrong. I read the chapter 4.4
documentation, which talked about ".putting /tools/bin ahead of the standard
PATH." and did this:


When the documentation clearly stated I should've done this:


This was on a "default" Slackware 10 system. Again, I'm not sure this caused
the problem, but it's the only thing I could think of, and, when I went back
and changed the PATH (and re-ran everything in Chapter 5, darn it!!), things
worked flawlessly.

Good luck!

- Mark

-----Original Message-----
From: lfs-support-bounces at
[mailto:lfs-support-bounces at] On Behalf Of Drunkalot
Sent: Wednesday, December 15, 2004 1:19 PM
To: LFS Suport
Subject: Error when configure glibc

The following error occurs when I'm try to run configure on the glibc
package in chapter 6 of lfs 6.0:

checking for C cleanup handling... no
configure: error: the compiler must support C cleanup handling

I think I do everything correct till here, and get no errors messages until

Does someone know what's happening???

More information about the lfs-support mailing list