2.6.2 kernal a must?

John Gay johngay at eircom.net
Wed Feb 23 11:15:49 PST 2005


On Wednesday 23 February 2005 18:40, jetfirespam wrote:
> At chapter 5.2, as directed, I compared the Host
> System Requirements against what my computer actually
> has. The results were as follows:
>
> Linux version 2.4.18-14
> (bhcompile at stripples.devel.redhat.com) (gcc version
> 3.2.20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4
> 13:35:50 EDT 2002
>
This is a rather old version.

> Now, the LFS book says the 2.6.2 kernel is required,
> whereas I seem to be running 2.4.x. Unfortunately, I'm
> not exactly clear on what the book wants me to do
> about this.
>
The host needs to be running a kernel newer than 2.6.1 for any of your build 
to work.

> Am I to compile and install a new kernel at this exact
> point, or does it not become necessary until Chapter
> 8, where the instructions for such a procedure are
> located? Because the emphasis seems to be on having
> gcc be version 3.x.x rather than having the newer
> kernel.
>
This could be quite difficult, as the 2.6 series kernel also requires other 
tools on your host to be updated.

A much easier way would be to start with a host that is already running a 2.6 
kernel. Even easier would be a liveCD such as Knoppix, which has a 2.6 kernel 
option, or the LFS LiveCD which was made for exactly this purpose, and also 
contains all the sources as well.

If you don't have broadband access for fetching ISO images to burn to disk, 
maybe someone close to you can burn one for you or check cheapdisks which 
should be able to sell you Knoppix quite cheap.

Cheers,

	John Gay



More information about the lfs-support mailing list