Problems while Login to LFS

Phoe6 orsenthil at gmail.com
Mon Feb 21 14:22:38 PST 2005


Gerard Beekmans <gerard at linuxfromscratch.org> wrote:
> On February 21, 2005 02:56 pm, Phoe6 wrote:
> > How should I be dealing with this?
> 
> Boot back into Fedora Core 3, mount LFS an chroot into it.
> 
> From within chroot, run: ldd /bin/login

ldd /bin/login

libshadow.so.0 => /lib/libshadow.so.0  (0xf6fce000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0xf6f8f000)
libc.so.6 => /lib/libc.so.6 (0xf6fc89000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0xf6fe7000)

> When you installed the Shadow package in Chapter 6, did you go through the
> configuration section? Did you enable shadow'ed passwords? Did you run
> "passwd root" to create a password for root?

Yes, I did pwconv, groconv and passwd root.

> While you're in chroot, make sure /etc/passwd contains this line:
> root:x:0:0:root:/root:/bin/bash

Yes, I does contain that line.

> And check the /etc/shadow file too. It will look something like:
> 
> root:$1$oNt8kY9/$sHh9Yl6vT6X.q1rF9pfP7.:12656:0:99999:7:::

Yes Gerard, my /etc/shadow has something similar as well.

I also created a user while in chroot and saw its reference at
/etc/passwd and /etc/shadow.

I also want to inform this( if its related or not): while booting up
the lfs is prompting me to enter the run level
Enter Run Level:
I enter 3 and it proceeds and then comes this  login problem.

I am willing to try further suggestions.

Regards,
Senthil



More information about the lfs-support mailing list