Upgrade LFS-3.0 to Build LFS-6.0 Problem 2

John McSwain jmcswain at infoave.net
Fri Sep 10 07:00:14 PDT 2004


Nico R. wrote:
> John McSwain wrote:
> [...]
>> $ ld -v
>> GNU ld version 2.11.2 (with BFD 2.11.2)
>
> Your binutils version is too old. You must upgrade to a version equal
> to or newer than from 2001-07-08 (see gas/ChangeLog-0001).
>
> Do *NOT* overwrite the binutils of your host system, as this will very
> probably screw up your system. Instead, you should install into a
> special prefix. You could also first upgrade to a more recent LFS
> version (3.3 is sufficient to handle this specific problem, as it
> includes binutils-2.12).
>
Thanks very much for this information.  Got something to work with now!

-- 
John McSwain
http://www.lakemcgregor.com/ 





More information about the lfs-support mailing list