Upgrade LFS-3.0 to Build LFS-6.0

John McSwain jmcswain at infoave.net
Tue Sep 7 11:50:35 PDT 2004


Matthias B. wrote:
> 2 suggestions:
>
> a) try `make bootstrap' instead of just `make'
>
> b) try an earlier version of gcc. I had no problems building 3.4.0 on
> my LFS 3.0 system

I tried gcc 3.4.0 with make and make bootstrap:

In file included from /usr/include/signal.h:358,
                 from ../../gcc-3.4.0/gcc/config/i386/linux.h:217,
                 from ./tm.h:11,
                 from ../../gcc-3.4.0/gcc/libgcc2.c:43:
/usr/include/bits/sigthread.h:36: error: storage class specified for 
parameter `type name'
make[3]: *** [libgcc/./_muldi3.o] Error 1
make[3]: Leaving directory `/usr/src/gcc-3.build/gcc'
make[2]: *** [libgcc.a] Error 2
make[2]: Leaving directory `/usr/src/gcc-3.build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/usr/src/gcc-3.build/gcc'
make: *** [bootstrap] Error 2

-- 
John McSwain
http://www.lakemcgregor.com/ 





More information about the lfs-support mailing list