(5.1.1) Configuration of dynamic loaded /usr/lib missing?

Geraint lfs at copyn.plus.com
Tue Nov 16 02:46:41 PST 2004

This is my first attempt, and I have a problem, question and an answer. 
  The main reason for posting is therefore so that someone else who has 
the same problem in the future may find my solution by searching the 

The test compile in chapter 6, after I readjusted the toolchain failed 
with a whole bunch of undefined references such as 
`_dl_lookup_versioned_symbol_skip at GLIBC_PRIVATE'.  For some reason 
/tools/lib/libc.so.6 couldn't find ld-linux.so.2.

I tried  "cc -v dummy.c" and found that the dynamic-linker was correctly 
set to /lib/ld-linux.so.2.  However, for some reason the linker was 
failing to find the ld-linux library.

I did a search through the archive and based on what I found I did a 
test and added a "/lib" to the start of /etc/ld.so.conf and everything 
worked fine.

So I asked myself - Why should the linker not be looking in /lib?  Is 
there a way of determining where it is looking by default?

I double checked my binutils pass 2 and found a really stupid typo - I 
had set the LIB_PATH incorrectly to /usr/lib;/lib (from know on cut and 
paste even the smallest commands!).  That answers the questions I guess.

Since rebuilding binutils is the next step I guess that all is not lost. 
  Once I rebuild binutils I'll remove the extra line from ld.so.conf and 
everything should be ok (he says hopefully!).


More information about the lfs-support mailing list