Binutils Pass 2 Compile Error

Eric Andres emandres at
Thu Nov 11 08:41:23 PST 2004


When I try to compile binutils on the second pass during chapter five,
I am getting an Error from the compiler.  Here's that relevant output:

file=../../../binutils-`echo fr | sed 's,.*/,,'`.gmo \
  && rm -f $file && PATH=../src:$PATH no -o $file
/bin/sh: line 1: no: command not found
make[3]: *** [] Error 127
make[3]: Leaving directory `/mnt/lfs/sources/binutils-build/bfd/po'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/mnt/lfs/sources/binutils-build/bfd'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/mnt/lfs/sources/binutils-build/bfd'
make: *** [all-bfd] Error 2

I've tried redoing it several times, with a make clean and with a
fresh source recompile.  The binutils build pass 1 worked fine for me.
 However, I might mention that I screwed and compiled glibc while su'd
to root.  When I realized I had made the mistake I just went into
/tools and chown'd all of the files and their contents to what the
other files were (lfs:lfs), rather than root:root.  Hope someone can

More information about the lfs-support mailing list