I can't boot my Sata drive (with lfs installed on it)

Cogman cogman at dcdi.net
Tue Nov 9 05:13:50 PST 2004


I cant figure this one out so hopefully you guys can help (the original 
messages where posted at 
http://forums.anandtech.com/messageview.aspx?catid=34&threadid=1431381&enterthread=y 
). Heres my problem.
" I have a sata hd and an IDE hd. The IDE currently has NTFS and windows 
XP. The sata is using Reiser and a LFS system. My problem is I cant boot 
up with grub. I have tried just about everything I can think of so I am 
coming here for help.

Currently my menu.lst looks like this (this is from memory as I'm typing 
in WinXP right now)

title LFS-6.0.....
root (hd1,0)
kernel /boot/lfskernel-2.6.8.1 root=/dev/hdg1 hdg=ide-scsi

This does not work, I have tried booting to the SATA drive (which has 
grub installed on its boot sector) and I cant get it or windows xp to go.

my current device setting is this.

IDE0 Master=CDRW DVD drive
IDE0 Slave=52x CDrom
IDE1 Master=80gig Maxator HD
SATA1=Hiachi 80gig drive.
(note that it is SATA1 and not SATA0, this was due to some earlier 
problems)
I have an Asus A8V WiFi Deluxe board (socket 939) with Bios version 1003 
installed.

After I reboot ill report the error I'm getting. LFS was installed using 
Knoppix v3.6 with kernel v2.6

Also I'm using Grub v0.95 )"

The error I'm getting is this
"root (hd0, 0)
Error 11: Unreconized Device string"
And just so you know, it is the same with root (hd1, 0)"

Both the Sata and the Windows XP drive have a boot loader on them, when 
booting windows XP from the PATA drive it hangs.  Any suggestions? 
(would I have more luck formating the drive to ext2/3 or XFS?) Also, 
whether or not this helps, LFS was installed with Knoppix 3.6 (2.6.7 
kernel) Knoppix detected the sata drive as hdg



More information about the lfs-support mailing list