wrong bash version??

J. Greenlees jaqui at telus.net
Sun Nov 7 09:20:48 PST 2004


Jeremy Huntwork wrote:
> On Sun, 2004-11-07 at 11:01 -0600, Kevin Alm wrote:
> 
>>----- Original Message -----
>>From: "J. Greenlees" <jaqui at telus.net>
>>To: "LFS Support List" <lfs-support at linuxfromscratch.org>
>>Sent: Sunday, November 07, 2004 10:08 AM
>>Subject: Re: wrong bash version??
>>
>>
>>
>>>Matthias B. wrote:
>>>
>>>>On Sat, 06 Nov 2004 21:34:27 -0800 "J. Greenlees" <jaqui at telus.net>
>>
>>wrote:
>>
>>>>
>>>>>just starting to build a lfs system, version 5.1.1 of the book
>>>>>and after setting up user and partition with no problems I run into a
>>>>>nice little problem.
>>>>>error message of wrong bash version cannot execute.
>>>>>running the configure script for binutils.
>>>>
>>>>
>>>>Please post copy'n'pasted messages with context (i.e. 10 to 20 lines
>>>>before the error) rather than telling us in your own words.
>>>>
>>>>MSB
>>>>
>>>
>>>okay, but we are talking only 5 lines before error.
>>>
>>>lfs at d142-173-80-210 lfs$echo $LFS
>>>/mnt/lfs
>>>lfs at d142-173-80-210 lfs$cd $LFS/temp/binutils-2.14/build
>>>lfs at d142-173-80-210 build$pwd
>>>/mnt/lfs/temp/binutils-2.14/build
>>>lfs at d142-173-80-210 build$../binutils-2.14/configure --prefix=/tools
>>>--disable-nls
>>>bash: ../binutils-2.14/configure /bin/sh: bad interpreter: permission
>>
>>denied
>>
>>>then edit configure to call bash not sh just in case
>>>bash: ../binutils-2.14/configure /bin/bash: bad interpreter: permission
>>>denied
>>>lfs at d142-173-80-210 build$bash --version
>>>GNU bash, version 2.05b.0(1)-release (i586-mandrake-linuc-gnu)
>>>Copyright (C) 2002 Free Software Foundation, Inc.
>>>
>>>Jaqui
>>>
>>
>>IIRC, that is the exact error (or very similar) you get when trying to build
>>lfs on a partition mounted with the wrong options. You probably didn't mount
>>with exec permision.
> 
> 
> Indeed, that's a possibility as well :)
> 
and it was the answer, defaulted to the noexec when I made the 
partition, cause I definately didn't enable it.
removed the option flag and presto, working.



More information about the lfs-support mailing list