fail to configure glibc-2.3.3-lfs-5.1 in chap06

Peter Hansen cyber_x at
Sun Nov 7 16:51:24 PST 2004

I have successfully completed chapter 5 (for the second time) but now in 
chapter 6 I get this error just after I issue this command

../glibc-2.3.3-lfs-5.1/configure --prefix=/usr \
    --disable-profile --enable-add-ons=linuxthreads \
    --libexecdir=/usr/lib --with-headers=/usr/include \

root:/source/glibc-build# ../glibc-2.3.3-lfs-5.1/configure --prefix=/usr 
--disable-profile --enable-add-ons=linuxthreads --libexecdir=/usr/lib 
--with-headers=/usr/include --without-cvs
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking sysdep dirs... sysdeps/i386/elf 
linuxthreads/sysdeps/unix/sysv/linux linuxthreads/sysdeps/pthread 
sysdeps/pthread linuxthreads/sysdeps/unix/sysv linuxthreads/sysdeps/unix 
linuxthreads/sysdeps/i386/i686 linuxthreads/sysdeps/i386 
sysdeps/unix/sysv/linux/i386 sysdeps/unix/sysv/linux sysdeps/gnu 
sysdeps/unix/common sysdeps/unix/mman sysdeps/unix/inet 
sysdeps/unix/sysv/i386 sysdeps/unix/sysv sysdeps/unix/i386 sysdeps/unix 
sysdeps/posix sysdeps/i386/i686/fpu sysdeps/i386/i686 sysdeps/i386/i486 
sysdeps/i386/fpu sysdeps/i386 sysdeps/wordsize-32 sysdeps/ieee754/ldbl-96 
sysdeps/ieee754/dbl-64 sysdeps/ieee754/flt-32 sysdeps/ieee754 
sysdeps/generic/elf sysdeps/generic
checking for a BSD-compatible install... /tools/bin/install -c
checking whether ln -s works... yes
checking for gcc... gcc
checking for suffix of object files... configure: error: cannot compute 
suffix of object files: cannot compile
See `config.log' for more details.

I have compiled the chapter 5 two times but I still get the same error, I'm 
running Slackware 10.0 - kernel 2.4.26

// McZ

Express yourself instantly with MSN Messenger! Download today it's FREE!

More information about the lfs-support mailing list