5.1 system running, but error compiling further packages (e.g. mc)

hh09 at onlinehome.de hh09 at onlinehome.de
Tue Mar 30 02:36:02 PST 2004


Chris Lingard <chris at stockwith.co.uk> schrieb am 29.03.2004, 16:53:45:
> hh09 at onlinehome.de wrote:
> 
> > 
> > hello world.
> > may I ask for help, regarding to following situation after successfully
> > (?) creating my lfs5.1 for my email/file-server (after 3 days hard
> > working - I'm not the linux-expert indeed).
> > 
> > history:
> > 
> > detailed going through the 5.1-book, creating the lfs step by step, all
> > the modules, all the tests and checks as recommended
> > 
> > rebooting new lfs51 is ok
> > 
> > compiling a package such as mc leads to breaks, because of missing bison
> > resp. flex.
> > reinstalling flex or bison isn't possible: each is depending on the
> > other to be installed first in some way (lex?).
> > 
> > do you have an idea?
> > hubert
> 
> Installing m4, bison, flex, in that order,  will work; unless you
> have a more serious problem than dependencies.
> 
> Chris
> 
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page

hello Chris,
I tried to re-arrange that situation with a new build of lfs5.1p1, now
logging all the actions.

but I failed - that means, the system is running now without that
behaviour (until yet).

as soon as I get that serious circle-dependency flex-bison again, I will
remember your advice.

thanks, hubert



More information about the lfs-support mailing list