5.1 system running, but error compiling further packages (e.g. mc)

Miguel Bazdresch lfs-01 at thewizardstower.org
Mon Mar 29 07:11:53 PST 2004


* hh09 at onlinehome.de <hh09 at onlinehome.de> [2004-03-29 17:03]:
> hello world.
> may I ask for help, regarding to following situation after successfully
> (?) creating my lfs5.1 for my email/file-server (after 3 days hard
> working - I'm not the linux-expert indeed).
> 
> history:
> 
> detailed going through the 5.1-book, creating the lfs step by step, all
> the modules, all the tests and checks as recommended
> 
> rebooting new lfs51 is ok
> 
> compiling a package such as mc leads to breaks, because of missing bison
> resp. flex. 
> reinstalling flex or bison isn't possible: each is depending on the
> other to be installed first in some way (lex?).

First, you probably should be doing LFS 5.0, not 5.1, which doesn't
exist, nor 5.1-pre, which is unstable :(

Second, it'd be great if you could show us exactly what you are doing:
which version of mc, which compilation steps, and especially, what
*exact* errors you're getting. See the faq on how to most efficiently
report errors.

-- 
Miguel Bazdresch
http://thewizardstower.org/



More information about the lfs-support mailing list