GLIBC Configure error

Richard Hamilton warbirdnut at ev1.net
Sat Mar 27 05:54:10 PST 2004


cd into your build directory then try the configure command and try 
specifying the full path to glibc. Something like this:

$LFS/sources/glibc-2.3.2/glibc-build/configure  ..........

I had the same problem and it worked worked for me in a couple of spots. 
I think there were a few other tools that required their own build 
directory. You might have to do the same thing on those as well.



Luis C. Wiedemann wrote:

> Hello All! I'm new to *nix so bare with me please.
> I am trying to get past the first part of the GLIBC installation. I 
> created the dir's without a hitch, yippee. I now have a glibc-build 
> dir, with the glibc-2.3.2 dir under that and when I am in the 
> glibc-2.3.2 dir and run the command
>  
> ../glibc-2.3.2/configure --prefix=/tools \
> --disable-profile --enable-add-ons \
> --with-headers=/tools/include \
> --with-binutils=/tools/bin \
> --without-gd
>  
> I get the following error,
> configure: error: you must configure in a separate build directory
>  
> I also tried to do htis in the sources dir with the same error msg.
>  
> I am a bit confused as to where I should be untarring and running 
> these commands from as the book doesn't seem to be specific. It 
> mentions how it assumes you are in the sources folder but how can that 
> be? the ../***/configure commands donned work from inside the sources 
> folder! I just un tar into the specific build folders for now and 
> configure and make from there but I'm not sure I am correct in doing that!
>  
> Thanks for any help you can offer me!!
>  
> Luis





More information about the lfs-support mailing list