Kernel panic: No init found...

andreasa at tmrsd.tch andreasa at tmrsd.tch
Tue Mar 23 06:26:52 PST 2004


On Tue, 23 Mar 2004 07:40:16 -0600, JazerNorth <jay at jaynorth.net> wrote:
> andreas wrote:
>> On Tue, 23 Mar 2004 11:06:48 +0100, Rainer Peter Feller <rainer at maren.desy.de> wrote:
>> 
>>>On Tue, 23 Mar 2004 andreas at linuxfromscratch.org wrote:
>>>
>>>>I got a
>>>>
>>>>Warning: unable to open an initial console.
>>>>Kernel panic: No init found. Try passing init= option to kernel.
>>>>
>>>>
>>>>What I checked so far:
>>>>
>>>>I use ext2 file system and the ext2 drivers are build into the kernel.
>>>>/sbin/init (of the LFS system) is present, owned by root an executable.
>>>>/dev/console (of LFS) is present, a char device and has the same rights
>>>>    a some other (LFS3.3) system on another computer
>>>>I tried to start with init=/bin/bash, but got the same result (Kernel
>>>>    panic)
>>>>
>>>>This is from the LFS 4.1.
>>>
>>>are you sure that you mount the right rootpartition?
>>>are you sure that elf execution is in then kernel?
>>>
>> 
>> 
>> Yes, /dev/hda3 and
>> yes, elf (but not a.out and misc)
>> 
>> 
>> But I have to admit, I'm not 100% sure about the mounting... I know that
>> in my lilo.conf, the kernel entry points to /dev/hda3, but I'm not 100%
>> sure my fstab has a /dev/hda3 / entry (no access from my office to the
>> not running computer, but I will check it as soon as I get there)
>> 
>> 
> I got the exact same thing.  Many times.  Come to find out, what you 
> thought was the correct setting in Grub is not.  For example, when I was 
> setting up my system, my LFS was on /dev/hdc2.  So I set Grub as hd2,1. 
>   But when I booted my system, it didn't work, so I had to set my Grub 
> as hd0,1.  Then I had to set my root=/dev/hdc2.  After I got both of 
> those settings correct, then it boots correctly.
>

Sorry, no Grub here, so I don't know what you mean by hd2,1 and hd0,1.

Thanks anyway, Andreas




More information about the lfs-support mailing list