Kernel panic: No init found...

Rainer Peter Feller rainer at maren.desy.de
Tue Mar 23 02:06:48 PST 2004


On Tue, 23 Mar 2004 andreas at linuxfromscratch.org wrote:

> Hi,

Hi,

> I'm feeling really bad, but I couldn't find a solution to this Kernel
> panic. I found some messages dealing with the same problem, but the
> didn't help me. Perhaps, there is some bright soul with some idea.
>
> I got a
>
> Warning: unable to open an initial console.
> Kernel panic: No init found. Try passing init= option to kernel.
>
>
> What I checked so far:
>
> I use ext2 file system and the ext2 drivers are build into the kernel.
> /sbin/init (of the LFS system) is present, owned by root an executable.
> /dev/console (of LFS) is present, a char device and has the same rights
>     a some other (LFS3.3) system on another computer
> I tried to start with init=/bin/bash, but got the same result (Kernel
>     panic)
>
> So I'm stuck. Please tell me where to go...
>
> This is from the LFS 4.1.
>
> Thanks, Andreas

are you sure that you mount the right rootpartition?
are you sure that elf execution is in then kernel?

  H
CUH Rainer Peter Feller
  H



More information about the lfs-support mailing list