LFS-5.0:Chapter-6:Autoconf-2.57 Error dumper.pm missing

JazerNorth jay at jaynorth.net
Mon Mar 22 10:33:18 PST 2004


JazerNorth wrote:

> I am using the LFS book 5.0 on an AMD (i686-pc-linux-gnu) system.  The
> dynamic loader is linux.so.2.  I have compiled all of the source to
> this point without any errors, except the known errors the book says
> is OK.  I am in chapter 6, page 151.  When compiling autoconf-2.57 I
> get the following:
> ---------------
> make[3]: Entering directory `/sources/autoconf-2.57/lib'
> rm -f autom4te.cfg autom4te.tmp
> sed -e 's, at SHELL\@,/bin/sh,g' -e 's, at PERL\@,/tools/bin/perl,g' -e
> 's, at bindir\@,/usr/bin,g' -e 's, at datadir\@,/usr/share/autoconf,g' -e
> 's, at prefix\@,/usr,g' -e
> 's, at autoconf-name\@,'`echo autoconf | sed 's,x,x,'`',g' -e
> 's, at autoheader-name\@,'`echo autoheader | sed 's,x,x,'`',g' -e
> 's, at autom4te-name\@,'`echo autom4te
> | sed 's,x,x,'`',g' -e 's, at M4\@,/usr/bin/m4,g' -e 's, at AWK\@,gawk,g' -e
> 's, at VERSION\@,2.57,g' -e 's, at PACKAGE_NAME\@,GNU Autoconf,g'
> ./autom4te.in >autom4te.tmpmv autom4te.tmp autom4te.cfg
> make[3]: Leaving directory `/sources/autoconf-2.57/lib'
> ../../tests/autom4te                            \
>         --language=m4sugar                      \
>         --freeze                        \
>         --output=m4sugar.m4f
> Can't locate Data/Dumper.pm in @INC (@INC contains:
> /sources/autoconf-2.57/lib
> /tools/lib/perl5/5.8.1/i686-linux /tools/lib/perl5/5.8.1
> /tools/lib/perl5/site_perl/5.8.1/i686-linux
> /tools/lib/perl5/site_perl/5.8.1 /tools/lib/perl5/site_perl .) at
> /sources/autoconf-2.57/bin/autom4te line 39.
> BEGIN failed--compilation aborted at
> /sources/autoconf-2.57/bin/autom4te line 39.
> make[2]: *** [m4sugar.m4f] Error 2
> make[2]: Leaving directory `/sources/autoconf-2.57/lib/m4sugar'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/sources/autoconf-2.57/lib'
> make: *** [all-recursive] Error 1
> --------------
> 
> Does anyone know how to fix this?  What steps do I need to take to
> troubleshoot an error as this?  Any help would be greatly appreciated.
> 
> Thank you.
> 
> JN
I had a link the link /usr/bin/perl to /tools/usr/bin/perl that was 
created in Chapter 5.  I removed the link and pointed it to 
/usr/bin/perl5.8.0 and now it works, so far anyway.


JN



More information about the lfs-support mailing list