Can't install Tcl 8.4.4

Sebastien Deligny sdeligny at tele2.fr
Sun Mar 21 23:03:01 PST 2004


I adjusted toolchain one more time and now I have this error:

gcc -pipe -rdynamic  tclAppInit.o -L/mnt/lfs/sources/tcl8.4.4/unix -ltcl8.4 
-ldl  -lieee -lm \
        -Wl,-rpath,/tools/lib -o tclsh
/lib/libc.so.6: undefined reference to `__libc_stack_end at GLIBC_2.1'
/usr/lib/libdl.so: undefined reference to `_dl_rtld_di_serinfo at GLIBC_PRIVATE'
collect2: ld returned 1 exit status
make: *** [tclsh] Error 1
[lfs at localhost unix]$

and I have an other problem, when I test the tools with "readelf -l a.out | 
grep ': /tools' I have this result:

[lfs at localhost lfs]$ echo 'main(){}' > dummy.c
[lfs at localhost lfs]$ gcc dummy.c
[lfs at localhost lfs]$ readelf -l a.out | grep ': /tools'
      [Requesting program interpreter: /tools/tools/lib/ld-linux.so.2]
[lfs at localhost lfs]$

But I can't find this path: /tools/tools/lib... I have only /tools/lib...

Seb.

On Fri, 2004-03-19 at 12:11, Sebastien Deligny wrote:

> Thanks for your help!

Are you sure you adjusted your toolchain properly?
Go back to the Adjusting your Toolchain section and verify that its done 
properly.

Nick

-- 
http://linuxfromscratch.org/mailman/listinfo/lfs-support
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page

> Hello,
>
> I'm trying to build a LFS system. I'm working with Mandrake 9.2 and using
> LFS 5.0 book (french version).
> Evrything goes fine up to installing Tcl8.4.4. When I try to build the
> package (make) I have this error:
>
> gcc -pipe -c -O -D__NO_STRING_INLINES -D__NO_MATH_INLINES -DTCL_DBGX= -Wall
> -Wconversion -Wno-implicit-int -fPIC -I./../generic -I. -fno-inline
> -DHAVE_UNISTD_H=1 -DHAVE_LIMITS_H=1 -D_LARGEFILE64_SOURCE=1
> -DTCL_WIDE_INT_IS_LONG=1 -DHAVE_GETCWD=1 -DHAVE_OPENDIR=1 -DHAVE_STRSTR=1
> -DHAVE_STRTOL=1 -DHAVE_STRTOLL=1 -DHAVE_STRTOULL=1 -DHAVE_TMPNAM=1
> -DHAVE_WAITPID=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_SYS_TIME_H=1
> -DTIME_WITH_SYS_TIME=1 -DHAVE_TM_ZONE=1 -DHAVE_GMTIME_R=1
> -DHAVE_LOCALTIME_R=1 -DHAVE_TM_GMTOFF=1 -DHAVE_TIMEZONE_VAR=1
> -DHAVE_ST_BLKSIZE=1 -Dstrtod=fixstrtod -DSTDC_HEADERS=1
> -DHAVE_SIGNED_CHAR=1 -DHAVE_LANGINFO=1 -DPEEK_XCLOSEIM=1
> -DHAVE_SYS_IOCTL_H=1
> -DTCL_SHLIB_EXT=\".so\" ./../compat/strstr.c
> ../compat/strstr.c: In function `strstr':
> ../compat/strstr.c:67: error: `NULL' undeclared (first use in this
> function) ../compat/strstr.c:67: error: (Each undeclared identifier is
> reported only once
> ../compat/strstr.c:67: error: for each function it appears in.)
> make: *** [strstr.o] Error 1
>
> I tried to do the same with the version 8.4.5 and I have the same error.
>
> When I do TZ=UTC make test, the same error again! (with the function
> strstr)
>
> Do I go ahead with make install despite this error?
>
> Thanks for your help!




More information about the lfs-support mailing list