Cursor Keys in vi?

Daniel Díaz al590349 at mail.mty.itesm.mx
Sat Mar 20 21:52:56 PST 2004


Hello.


On Sat, 2004-03-13 at 13:27, Bill's LFS Login wrote:
> On Sat, 13 Mar 2004, Daniel [ISO-8859-1] Daz wrote:
> 
> > Does anybody knows the answer to the original question? I happen to have
> > the same problem with my LFS 5.0.
> >
> > I think it is related to the xterm terminal, because that's reported on
> > X and on a SSH session. This only happens with vi, nano, and the like;
> > bash is ok.
> >
> > The cursor keys work fine in nano, but end-of-line and beginning-of-line
> > do not seem to work (they show an H or an F letter instead). (The
> > letter+newline happens on vi, also.)
> >
> > I have tried many inputrc configurations, but none of them work
> > properly.
> >
> > Any hint on where to look?
> 
> I just use what is in the BLFS book and have few problems, IIRC.

I hate these keyboard issues. My desktop Mandrakes always have this
annoying bug of Mod2 sticking after switching to the Spanish layout;
it's impossible to gain focus with a click after that (Mod2-click screws
up things). I guess it's a hardware thing, for all the keyboards I've
tried do the same thing with MDK.

In LFS' case, on the other hand, it's an iBook, so maybe the Mac
keyboard is doing something wrong. I've tried already Debian and Gentoo
PPC's keyboard layouts and stuff, but nothing does the trick.

As I said, it only happens within X. And furthermore, within X only
happens when in nano, less, or the like. On remote shells (to the
outside) it works ok, but not on the other way around. On virtual
consoles it works fine, also.

I'm running GNOME 2.4 from CVS' BLFS.

I think I rather accept it and go on with life.

Thanks for your reply! Greetings.

Daniel Díaz
yosoy at danieldiaz.org

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20040320/454d41da/attachment.sig>


More information about the lfs-support mailing list