Tar-1.13.25 Build Error - Chapter 5

John Benes smartcat99s at stgeorges.myvnc.com
Sat Mar 20 07:25:14 PST 2004



> On Fri, 19 Mar 2004, John wrote:
> 
> > > Matthew Burgess wrote:
> > > >On Wed, 17 Mar 2004 13:55:11 -0600
> > > >John <jim.benes at netzero.net> wrote:
> > > >
> > > >>Bringing this up again, since noone has solved it yet...
> > > >>
> > > >>if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../intl    -g -O2 -MT getdate.o
> > > >>-MD -MP -MF ".deps/getdate.Tpo" -c -o getdate.o getdate.c; \
> > > >>then mv -f ".deps/getdate.Tpo" ".deps/getdate.Po";
> > > >>
> > > >>else rm -f ".deps/getdate.Tpo"; exit 1; fi
> > > >>getdate.y: In function `yyparse':
> > > >>getdate.y:381: error: parse error before '}' token
> > > >>
> > > >>
> > > >
> > > >What version of bison & flex are you using?  yyparse errors bring
> > > >back horrible memories of flex-2.5.31.
> > > >
> > > >
> > > I was using flex-2.5.4
> > updated to flex-2.5.4a, bison 1.75
> > still fails
> 
> I've not saved your OP, but did you apply the needed patch for bison?
> IIRC, it's in the book and it is available from the patches download
> area. I don't know if this affects your problem either.

no.. i didn't know there was one needed... problem was on host machine side, not lfs.

> 
> My last build though was a 5.0+ (CVS around December?) so I've no solid
> suggestions about whatever version you're building ATM.
> 

am going to start over... different host system (going to Suse 9)



More information about the lfs-support mailing list