binutils-2.14 - pass 1 LFS-5.0 build error

Roman Kaganovich nospam at nospam.com
Sat Mar 13 23:53:50 PST 2004


You are right.
I returned to "old" version of gcc - 2.96 and successfully rebuild 
binutils-2.14.

Thanks.


Miguel Bazdresch wrote:
> * Roman Kaganovich <nospam at nospam.com> [2004-03-13 13:02]:
> 
>>When running command:
>>
>> make LDFLAGS="-all-static"
>>
>>/usr/bin/ld: Dwarf Error: Invalid or unhandled FORM value: 14.
> 
> 
> Type this error into Google, then hit the "i'm feeling lucky" button.
> You'll find that apparently you need to upgrade binutils in your host.
> It's hard to say if that will fix your problem but it's worth a shot I
> think.
> 
> There are people like Ryan building from very old hosts, and this hadn't
> been reported before IIRC. I infer from the thread that Google finds that
> the problem might be you have upgraded gcc in your host without
> upgrading the rest of the toolchain.
> 




More information about the lfs-support mailing list