unforseen error in /etc/rc.d/rcsysinit.d/S40mountfs!!!!!!

faza faza000 at op.pl
Wed Mar 3 11:57:26 PST 2004


Ken Moffat wrote:


well, here is the respons.... :)


>  First, to try to fix the failing mount(s), from chroot edit the LFS
> /etc/fstab to comment out everything you don't need, i.e. devpts and
> shm.  If that doesn't cause mount to succeed, comment out the swap entry
> as well.  (I'm guessing the errors are either missing mount points, or
> failure to mkswap).

  so after probing out some confs in /etc/fstab , this worked for me:

#begin /etc/fstab

# filesystem  mount-point    fs-type  options         dump   fsck-order

/dev/hdb1     /              ext2     defaults        1      1
/dev/hdb2     swap           swap     pri=1           0      0
proc          /proc          proc     defaults        0      0
#devpts        /dev/pts       devpts   gid=4,mode=620  0      0
shm           /dev/shm       tmpfs    defaults        0      0
#usbfs         /proc/bus/usb  usbfs    defaults        0      0

#end /etc/fstab

i think: (now , i'm able to ..... , cause last night [3:00 am] i 
couldn't realise ... the fact that the : can't locate module devpts 
error has something to do with the unforseen error !!!thanks for help in 
this one!!!)

for #devpts: compiling dev/pts file suport into the kernel will solve 
the prob (probably oversaw, this option last time,)

and for #usbfs: i probably should first add the device with makedev,
make the mount point (cause the output was something like "no mount 
points defined")

after that i should finaly get rid of my unforseen error prob

again thanks

unfortunatly like u said , there is still the bash error so :


>  When you've got mount succeeding, turn to the second error.  The error
> message you posted has a space between the '/bin/bash' and the ':'.  Was
> that a typo in your posting ? 

no it wasn't ,but for shure i will retype this one:

so after typing the password i got this output:

lfs login:

Last login: Tue Mar  2 22:46:24 +0100 2004 on tty1
No mail

Cannot execute /bin/bash : No such file or directory



after this error i have again :

lfs login:

...so i can again log in and retype the password and i got again the 
same error....

	and btw the system is working just fine (my sisters comp was trying to 
connect via the home lan , and i had some output about that , also had 
some output when phone was ringing [got isdn]) , anyway its quiet off 
topic here .....

any idea how to fix this one??????






>   Is the problem the same on the
> other consoles ?
> 

unfortunatly like u said , there is still the bash error so :










More information about the lfs-support mailing list