LFS-5.1-pre1/Chapter5/glibc-2.3.3 install problem (sln) : Illegal Instruction

EC NOSPAM_wwwingman at bigfoot.com
Wed Mar 3 00:32:38 PST 2004


Hello,

Newbie to LFS, I need some help on build the LFS-5.1-pre1. Tried to build
using the book and later using nALFS (great). I have the same problem, so I
suppose it may come from the packages / configuration.

Pb occurs on chapter 5, glibc 2.3.3 install (compilation ok). Seems the sln
command answers always Illegal instruction. Here's the output I get:

>>>>>>
x-: then echo 'stubs.h unchanged'; \
x
x-: else /usr/bin/install -c -m 644 /mnt/lfs/tools/build/glibc-build/stubs.h
/tools/include/gnu/stubs.h; fi   x
x-: rm -f /mnt/lfs/tools/build/glibc-build/stubs.h
x
x-: /mnt/lfs/tools/build/glibc-build/elf/sln
/mnt/lfs/tools/build/glibc-build/elf/symlink.list                x
x-: make[1]: *** [install-symbolic-link] Illegal instruction
x
x-: make[1]: Leaving directory `/mnt/lfs/tools/build/glibc-2.3.3-20031202'
x
x-: make: *** [install] Error 2
<<<<<<

My LFS is build using a freshly installed debian woody. Machine is a PIII
550 (can this be a problem, I think I saw something about that...).

Finally, I tried compiling the LFS 5.0-pre3, and it works fine for me...

Hope you can help.
EC.





More information about the lfs-support mailing list