unforseen error in /etc/rc.d/rcsysinit.d/S40mountfs!!!!!!

faza faza000 at op.pl
Tue Mar 2 17:00:28 PST 2004


Nathan Coulson wrote:
>>hi ,
>>i have almost build the system but after i try to boot lfs 5.0
>>i got this error:
>>
>>unforseen error in /etc/rc.d/rcsysinit.d/S40mountfs
>>wich exited with a return value of 96
>>
>>i'm still able to login but after i enter the password i got this:
>>
>>cannot execute /bin/bash :
>>no such file or directory
>>
>>my guess is: my lfs is pointing to the /bin/bash in my host system (red
>>hat 8.0), however it doesn't make any sens to me cause during the build
>>everything worked fine , also when i was chrooting things were going as
>>written in the book.
>>
>>
>>dunno maybe the unforseen error has something to do with it...
>>
>>btw, i tried to run in the chroot env the mountfs script in
>>/etc/rc.d/init.d/ to wich the S40mountfs points to and i got something
>>like this:
>>
>>Remounting root file system in r-w mode.... ok
>>Recording existing mounts in /etc/mtab..... ok
>>Mounting remaining file systems....
>>mount: devpts already mounted or devpts
>>busy..                                     failed
>>
>>but it wasn't mounted so i dunno why this error
>>
>>
>>nevertheless i think the script is working just fine , so i still can't
>>understand why the unforseen error -> my first guess was the script is
>>bugy
>>
>>
>>i installed lfs-5.0 from the host ditro red hat 8.0 (the ditro is on my
>>raid aray (stripping 2+0) the lfs is on my normal hdd )
>>yes i know , this is not quiet a stnd configuration ,
>>
>>i also have'nt set up the modules.conf file ,yet but i dont think it
>>really matters at least according to the  "cannot execute /bin/bash"
>>error ....
>>
>>thanks
>>
>>faza
> 
> 
> Well, it probably doesnt help here, but your error 96, on mount means
>        32     mount failure
>        64     some mount succeeded
> [taken from man mount, add the 2 #'s together]
> 
> It is probably because of the wrong values in /etc/fstab.
> 
> If you are able to post your /etc/fstab [lfs's that is] here, as well as a
> breakdown of your partitioning skeme, I will be able to provide further
> information.


so my /etc/fstab looks like this:

#begin /etc/fstab

# filesystem  mount-point    fs-type  options         dump   fsck-order

/dev/hdb1     /              ext2     defaults        1      1
/dev/hdb2     swap           swap     pri=1           0      0
proc          /proc          proc     defaults        0      0
devpts        /dev/pts       devpts   gid=4,mode=620  0      0
shm           /dev/shm       tmpfs    defaults        0      0
#usbfs         /proc/bus/usb  usbfs    defaults        0      0

#end /etc/fstab

i set the fs-type to ext2, should i follow the books example and set 
reiserfs???


and the partiton skeme:(i hope u have mean that, couse i'm not sure if 
there is a diffrence betwen a skeme and table)


Disk /dev/hdb: 255 heads, 63 sectors, 4865 cylinders
Units = cylinders of 16065 * 512 bytes

    Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1       510   4096543+  83  Linux
/dev/hdb2           511       608    787185   82  Linux swap
/dev/hdb3           609      4865  34194352+   f  Win95 Ext'd (LBA)
/dev/hdb5           609      4865  34194321    c  Win95 FAT32 (LBA)



More information about the lfs-support mailing list