unforseen error in /etc/rc.d/rcsysinit.d/S40mountfs!!!!!!

faza faza000 at op.pl
Tue Mar 2 16:23:08 PST 2004


hi ,
i have almost build the system but after i try to boot lfs 5.0
i got this error:

unforseen error in /etc/rc.d/rcsysinit.d/S40mountfs
wich exited with a return value of 96

i'm still able to login but after i enter the password i got this:

cannot execute /bin/bash :
no such file or directory

my guess is: my lfs is pointing to the /bin/bash in my host system (red 
hat 8.0), however it doesn't make any sens to me cause during the build
everything worked fine , also when i was chrooting things were going as
written in the book.


dunno maybe the unforseen error has something to do with it...

btw, i tried to run in the chroot env the mountfs script in 
/etc/rc.d/init.d/ to wich the S40mountfs points to and i got something
like this:

Remounting root file system in r-w mode.... ok
Recording existing mounts in /etc/mtab..... ok
Mounting remaining file systems....
mount: devpts already mounted or devpts
busy..                                     failed

but it wasn't mounted so i dunno why this error


nevertheless i think the script is working just fine , so i still can't 
understand why the unforseen error -> my first guess was the script is bugy


i installed lfs-5.0 from the host ditro red hat 8.0 (the ditro is on my
raid aray (stripping 2+0) the lfs is on my normal hdd )
yes i know , this is not quiet a stnd configuration ,

i also have'nt set up the modules.conf file ,yet but i dont think it
really matters at least according to the  "cannot execute /bin/bash"
error ....

thanks

faza




More information about the lfs-support mailing list