LFS 5.1 Chapter 6: Installing Glibc-2.3.3 fails

Amit Sharma amit at zuberon.com
Mon Mar 1 17:35:45 PST 2004


Hi,

I followed all instructions on "Linux From Scratch: Version 5.1-pre1" to 
the letter and everything worked except one minor glitch until I came to 
this section.

Chapter 6: Installing Glibc-2.3.3

The .configure failed, after some digging I found that /tools/bin/gcc 
could not compile any .c program from the chroot environment. I could 
use this as the lfs user and had compiled all the packages in chapter 5 
just fine. gcc would fails with a comment could not execute 
"/tools/bin/as" no such file or directory. The file does exsist and is 
world executable.

Strangely "ls as" works but executing "as" does not. Here's what I tried.

root:/# ls /tools/bin/as
/tools/bin/as
root:/# /tools/bin/as
bash: /tools/bin/as: No such file or directory

This is not related but previously I had to work around the following.

Chapther 5: Insatlling Perl

I could not .configure the perl package, it failed bacuause it could not 
get to libgpm.so.1. It was becaus perl configure scripts were invoking a 
new  shell( This being the bash shell /mnt/tools/bin/bash)  was  not 
looking into /usr/lib for the libraries.  I got round  this by setting 
the LD_LIBRARY_PATH=$LFS/tools/lib:/usr/lib.


Thanks,
Amit



More information about the lfs-support mailing list