Old GLIBC on LFS

Rainer Peter Feller rainer at maren.desy.de
Wed Jun 30 23:55:44 PDT 2004


On Wed, 30 Jun 2004, Renato Riolino wrote:

> Em Ter, 2004-06-29 às 03:00,
>
> Right, but I've see on some distros (RPM based) packages named
> compat-glibc or something like this.
>
> What I want to do is install an older glibc on a different path and
> change just on that app to use, for exemple,
> /opt/old-glibc/lib/ld-linux.so.2 . Any chances?
>
> Thanks
>
> Renato
>
> > ------------------------------
> >
> > Message: 16
> > Date: Mon, 28 Jun 2004 18:13:40 -0700
> > From: "Kevin P. Fleming" <kpfleming at linuxfromscratch.org>
> > Subject: Re: Old GLIBC on LFS
> > To: LFS Support List <lfs-support at linuxfromscratch.org>
> > Message-ID: <40E0C244.80506 at linuxfromscratch.org>
> > Content-Type: text/plain; charset=us-ascii; format=flowed
> >
> > Renato Riolino wrote:
> >
> > > ./sc3u: relocation error: ./sc3u: symbol _dl_global_scope, version
> > > GLIBC_2.0 not defined in file ld-linux.so.2 with link time reference
> > >
> > > I think this mean that it was linked against GLIBC 2.0, so a possible
> > > fix would be install glibc 2.0 on my system.
> > >
> > > Is it possible to install an old glibc for use with only one especific
> > > app?
> >
> >
> > Your analysis is correct. Unfortunately, installing an older glibc would
> > be very difficult, if it's possible at all.
> >
> > ------------------------------

hm ... with glibc-2.3.2 I do this :
  sed s%"compat_symbol.*GLIBC_2_.);"%""% -i ctype/ctype-info.c
  sed s%"compat_symbol.*GLIBC_2_.);"%""% -i locale/lc-ctype.c
I don't know if it will also work for 2.3.3 but I suppose it would ...
and for me it looks like if this makes the glibc-2.3.2 compatible to
older versions of glibc-2

  H
CUH Rainer Peter Feller
  H



More information about the lfs-support mailing list