Linux Advisory updates

Ken Moffat ken at kenmoffat.uklinux.net
Wed Jun 30 10:29:27 PDT 2004


On Wed, 30 Jun 2004, Vaughn, Nathaniel (N-DCT Systems) wrote:

> Regards,
>
> I have successfully gotten LFS 5.1 running great on three Platforms w/
> a little tweaking (X86, SPARC, PPC).  My question to you all is when

 Nice, feel free to stick around for the occasional non-x86 questions :)

> advisories arise.  What is the LFS way of fixing the problem software.
> I would assume that we are suppose to just download the latest source
> from say freshmeat, and install?  However, the LFS install, points out
> that the chosen packages have been tested to be compatible.  So, do we
> run the risk of breaking the machine totally by upgrading (note:
> wouldn't be the first time for me)  All comments are welcome.  I could
> not find any relevant data on the site or archives, but I admit to
> being a newbie.  Thanks
>
> Nated00g
>
>

 Mostly, advisories are for BLFS or the kernel.  Normally, upgrading to
a newer kernel in the same stable series, starting with your old config,
doesn't break anything.  Occasionally, it does, so at a minimum you want
to keep your old kernel around and have a recovery procedure (I'm
thinking particularly of occasional bootloader problems).

 BLFS stuff is usually much less critical to system stability.

 And if an advisory comes out for something installed in LFS you
probably want to watch lfs-security and maybe lfs-dev to see if an
upgrade will cause grief.

 If the package is part of the toolchain, it's probably time to do a
test reinstall.

Ken

-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the lfs-support mailing list