[LFS 5.1.1] glibc 2.3.3 make check mtrace problem (again)

Georgi Chulkov g9405 at dir.bg
Wed Jun 30 02:38:57 PDT 2004

Dear LFS community,

I am a complete newbie to LFS (although I have some Linux experience).
I am trying to build LFS 5.1.1 following the book exactly. Everything
until glibc installation in chapter 6 has worked just as expected. I
congure and make glibc without probems, but make check returns the
following error (I think that should be the beginning of the error):

/bin/sh: line 1: /sources/glibc_build/malloc/mtrace: No such file or

My computer is a Dell Latitude D800 laptop, 1.3, 512 ram, and my LFS
partition is 4 gb. My host system is Knoppix 3.4.

I have searched through the archives of lfs-support and found that perl
is the most likely problem. Indeed, when installing perl, i had typed
per15 instead of perl5. I fixed it, rebooted, tried again (with a
freshly tar-d, configure-d and make-d glibc) but the same error was
still there. I tried yet once again everything from perl installation
on, but with no success.

What should I do? Please tell me if you need more information.


More information about the lfs-support mailing list