Konsole not working for users

Ken Moffat ken at kenmoffat.uklinux.net
Mon Jun 28 06:12:53 PDT 2004

On Mon, 28 Jun 2004, Andrew Sharp wrote:

> Dear support,
> I have tried to get help from the irc chatroom for a few days without any
> qualified success.
> I installed KDE 3.2.0 and found that Konsole worked well in root, but not in
> any user modes. It is a dead window although the tip of the day appears and I
> can open any type of console. However, there is no prompt and the keyboard is
> dead.
> With some help from Roel on IRC, I have run 'konsole &' in an xterm to get the
> error 'kdecore (KProcess): WARNING: Can't open a pseudo teletype'. Any
> attempt to use the shell gives in xterm 'Uh oh.. can't write data..'
> Overnight, I updated KDE libs and base to 3.2.3 in vain and reinstalled Tk,
> Tcl and expect in BLFS (using usr for tools mode), making sure there were no
> problems there.
> How do I solve this problem?
> Andrew Sharp

 No idea, but I wonder if this is another variant on "userspace doesn't
understand the new pty numbering" ?  Are you using an LFS built against
2.4 headers, but running a 2.6 kernel ?  There was a question about that
sort of thing on lkml recently, and the latest bk snapshots of the
kernel are supposed to fix it (recent 2.6 kernels have used increasing
numbers for the next /dev/pty, the fix is supposedly to reuse from
available low numbers).

 If not, which version of LFS is this ?

 das eine Mal als Tragödie, das andere Mal als Farce

More information about the lfs-support mailing list