Freeing unused memory and cpu type newslist at
Sun Jun 27 06:57:58 PDT 2004

Hi Ronald,

I noticed that when compiling the first package (binutils-2.14) and
selecting i386 as target system, the "make configure-host" fails. The error

checking for stdlib.h... (cached) yes
*** BFD does not support target i386-pc-none.
*** Look in bfd/config.bfd for supported targets.
make: *** [configure-opcodes] Error 1

When I change CHOST="i386" to CHOST="i386-linux-gnu" it works perfectly.
(CFLAGS="-march=i386" and CXXFLAGS="-march=i386" remain the same)

My buildplatform is Fedora 1 running gcc 3.3.1 and I tried it on a Slackware
9.1 running 3.2.3 but both gave me the same error message. After I changed
CHOST, both platforms could compile ok.


"Ronald Hummelink" <maillist at> schreef in bericht
news:40D7845A.9080101 at
> wrote:
> > Hi all,
> >
> > I just finished my own lfs installation, but when  I try to boot my new
> > system it stalls at "Freeing unused memory". Reading all the mail about
> > problem, it seems that it has something to do with my CPU. I compiled
> > lfs system on a PIII and then transfered it to a PI system. Apperently
> > the code has been compiled for i686 instead of i386. Is this correct?
> > I recompile all the code for i386 and than it should work?
> >
> > If someone has some thoughts about it let me know...
> >
> > Rene
> >
> >
> Take a look at the crosscompiling-x86 hint...
> in particular look at the uname hack which makes it really all
> transparent...
> Ronald

More information about the lfs-support mailing list