problem with make install of glibc

Gilles Espinasse g.esp at free.fr
Wed Jun 23 06:58:37 PDT 2004


Selon Ken Moffat <ken at kenmoffat.uklinux.net>:

> On Wed, 23 Jun 2004, S.J. van Atteveldt wrote:
> 
> > I am trying to install LFS5.1.1 and in chapter 5 I get problems with
> > make install of the glibc package. I have done the previous steps, the
> > last being
> > 	make AUTOCONF=no
> > but when I proceed to make install I get the following message...
> >
> > debian:~/target# su - lfs
> > No directory, logging in with HOME=/
> 
> 
> > make[1]: Entering directory `/root/target/sources/glibc-2.3.3-lfs-5.1'
> > autoconf  sysdeps/i386/elf/configure.in > sysdeps/i386/elf/configure.new
> > autoconf: Undefined macros:
> > ***BUG in Autoconf--please report*** AC_FD_MSG
> > make[1]: *** [sysdeps/i386/elf/configure] Error 1
> > make[1]: Leaving directory `/root/target/sources/glibc-2.3.3-lfs-5.1'
> > make: *** [install] Error 2
> >
> > Anyone seen this before?
> >
> > Bas.
> >
> >
> 
>  I've not seen it myself, perhaps because my debian system ended up
> as an unholy mixture of stable and testing, but there have been recent
> suggestions that autoconf on your host needs to be updated.
> 
> Ken
> -- 
Explanation and solutions are described there
http://linuxfromscratch.org/pipermail/lfs-support/2004-June/023875.html

Adding 'AUTOCONF=no' is the solution adopted in IPCop now LFS5.1.1 based build 
script.
This was reported to solve the problem with debian boxes.

Gilles



More information about the lfs-support mailing list