SV: Unable to umount /mnt/lfs: Device is busy

Andre nospam at spam.net
Fri Jun 18 09:21:16 PDT 2004


I always make the mistake of being in a subdirectory of the mountpoint, so
make sure you cd out of there before doing the unmount.

Also, take a look at the output from ps and see whether there are any other
shells (that you might have forgotten about) that could be cd into that
partition. You will also be able to see any tasks that are nonops. I would
just start killing them one by one, and retry unmount.

--
================================
People who are organized are too lazy
to look for things - [unknown]
=====LFS registered user #12491=====


"Chris Lingard" <chris at stockwith.co.uk> wrote in message
news:cauu9m$aeu$1 at belgarath.linuxfromscratch.org...
> Anders Lingfors wrote:
>
> > Well... Most of the installation was made over SSH from another
> > computer... However, I am now using directly on the LFS computer, and I
> > have logged out and then logged in again, using my new system. The
problem
> > still remains.
> >
> > I guess I have to reboot with the /mnt/lfs still mounted and hope my
> > system will not be FUBAR'd, if nobody else can give me more detailed
ways
> > to troubleshoot...
>
>
> Have you unmounted /mnt/lfs/proc' ($LFS/proc)?  Also have you mounted
> anything else there.  (Try cat /proc/mounts to see what it thinks is
> mounted)
>
> Other that that, exit chroot; make sure that no user is within that area
> and it should unmount
>
> Chris
>





More information about the lfs-support mailing list