coreutils ch6 test fail (touch can change timestamp for / when non root !!!!)

Henry K van Eyken vaneyken at sympatico.ca
Sat Jan 31 04:49:01 PST 2004


On Sat, 2004-01-31 at 03:39, Méher Khiari (E-mail) wrote:
> Hi all
> I am testing LFS 5.0 (host RH 9.0)
> All went well (although the tests for the gcc was slightly different, but it
> don't seem the cause).
> The user tests for coreutils fails on touch. I tried to guess the pb and I
> was surprised.
> I tried to switch manually to user dummy (su dummy), executed "touch /" and
> it worked (normally it is a permission denied, but the timestamp was really
> changed).
> the owner of "/" is root and is not writable by anyone else !!
> And that's why the test fail !!
> I won't let this security pb go !
> but I don't have any clue about this !!
> does anyone have any idea ?!
> bye

Meher.

I _seem_ to have some trouble with Coreutils (Ch.6) as well. Also on RedHat 9.
While I am looking to see what I may have done wrong and doing a reinstall,
of Coreutils and two subsequent packages, please tell me what you mean by 
"pb" in the phrase "I tried to guess the pb."

And, yes, I had one slightly different test result fir gcc, but failed to 
record it as it seemed insignificant. Maybe the same as you(?)

Henry




More information about the lfs-support mailing list