strange badblocks problem

marnixk lfs at mkaart.net
Sun Jan 18 02:33:08 PST 2004


Alex Groenewoud wrote:

> marnixk wrote:
>> cdimage root # badblocks -v /dev/hda8
>> Checking for bad blocks in read-only mode
>> >From block 0 to 3036253
>> 3036252
>> Pass completed, 1 bad blocks found.
> 
> I've seen something like this too, but cannot now reproduce it.  At the
> time I was puzzled, but decided that it was a miscalculation on the part
> of badblocks.  What version of badblocks are you using?  Your output
> seems to suggest it is not the latest.  Mine shows this:
> 
> #root:/# badblocks -v /dev/hda5
> Checking blocks 0 to 200781
> Checking for bad blocks (read-only test): done
> Pass completed, 0 bad blocks found.

See my last post on the badblocks stuff....

> However, your experience with dd and cat and mount/umount makes it look
> like mount or umount confuses the kernel about the precise size of the
> filesystem.  Have you tried different kernels?  (That's a bit hard with
> a live-CD, but you could try it with the Debian system.)

I have also seen this on a Debian machine (kernel 2.4.24) and i've tried
both the vanilla and the gentoo kernel (2.4.24 and 2.4.22) on my gentoo
machine. I am guessing it might be something with the kernel (maybe
something in both .22 and .24), but repartitioning my drive so that the
partitions have a number of sectors in them that are divisible by 8 should
also work.

Thanks!
Marnix



More information about the lfs-support mailing list