Glibc won't Lock in

Greg Schafer gschafer at zip.com.au
Wed Jan 14 18:43:49 PST 2004


On Wed, Jan 14, 2004 at 08:29:51PM -0600, John Cheyney wrote:
> On Wed, 2004-01-14 at 16:54, Greg Schafer wrote:
> > On Tue, Jan 13, 2004 at 09:21:40PM -0600, John Cheyney wrote:
> > > I finally got my Glibc to configure and install.  I had misread a couple
> > > of steps and was hopelessly lost, so I just went back to square one.  
> > > 
> > > Now the problem comes with the next step.  When I try to amend the GCC
> > > specs file and I issue the commands as ordered
> > > (SPECFILE=/tools/lib/gcc-lib/*/*/specs, etc) I get the following errors
> > > 
> > > [1]26212
> > > bash:  tempspecfile:  No such file or directory.
> > 
> > Are you cutting and pasting the commands for this as recommended in the
> > book? If you're not real familiar with shell commands then this lockin step
> > can go awry if you're not careful.
> Yes.  It still doesn't help.  When I run the sanity check I still get
> nothing.

There is no point in running the sanity check if the commands are failing!
You need to figure out why the commands are failing.

Please cut and paste the below, press enter, then show us the output (and error
if any) - be careful of wordwrap:

SPECFILE=/tools/lib/gcc-lib/*/*/specs &&
sed -e 's@ /lib/ld-linux.so.2@ /tools/lib/ld-linux.so.2 at g' $SPECFILE > tempspecfile &&
mv -f tempspecfile $SPECFILE &&
unset SPECFILE

If no error, then please physically "eyeball" the specs file and see if the
intended change was made. This is all explained in the book. I fail to see
why this is a problem for you.



More information about the lfs-support mailing list