Coreutils-5.0, Chapter 6: Test Error

Serge Denault tangoparis at hotmail.com
Tue Jan 13 22:21:05 PST 2004


Good day everyone,

Well I'm stuck: I have tried several times to install this package and I
always get the same error at one point during the test performed by the
dummy user.

For what it counts, my distribution is SuSE 9.

Here is the part displaying the error:


********************************************
NOTICE: Some tests will or might need to be
        run as root. Do `make check-root'
        as `root' to run just these tests.
********************************************
Making check in basename
make[2]: Entering directory `/sources/coreutils-5.0/tests/basename'
make  check-TESTS
make[3]: Entering directory `/sources/coreutils-5.0/tests/basename'
Can't locate IO/File.pm in @INC (@INC contains: ./.. /tools/lib/perl5/5.8.0
i686-linux /tools/lib/perl5/5.8.0 /tools/lib/perl5/site_perl/5.8.0
i686-linux /tools/lib/perl5/site_perl/5.8.0 /tools/lib/perl5/site_perl .)
at /tools/lib/perl5/5.8.0/FileHandle.pm line 9.
Compilation failed in require at ../Fetish.pm line 11.
BEGIN failed--compilation aborted at ../Fetish.pm line 11.
Compilation failed in require.
BEGIN failed--compilation aborted.
FAIL: basic
======================================
1 of 1 tests failed
Please report to bug-coreutils at gnu.org
======================================
make[3]: *** [check-TESTS] Error 1
make[3]: Leaving directory `/sources/coreutils-5.0/tests/basename'
make[2]: *** [check-am] Error 2
make[2]: Leaving directory `/sources/coreutils-5.0/tests/basename'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/sources/coreutils-5.0/tests'
make: *** [check-recursive] Error 1

Does anyone has an idea where I should start looking?

Many thaks in advance for any help!




More information about the lfs-support mailing list