Chapter 5 Perl Make problem

steve huskey iccaros at comcast.net
Mon Jan 12 18:29:07 PST 2004


On Mon, 2004-01-12 at 15:33, Steven Brown wrote:
> Hi there,
> 
> I'm having a problem doing the 
> 
> make perl utlities
> 
> command in Chapter 5 of LFS 5.
> 
> configure seems to go ok, but the make exits like this -
> 
> cc: lib/auto/l0/l0.a: No such file or directory
> make: *** [perl] Error 1
> 
> i've found similar problems on the archive, but not really anything with a
> satisfactory answer.
> 
> my rough guess is that I'm maybe making a mess of the line that goes into
> hints/linux.sh, at first I was using 1 (one) rather than l (L), but both
> bring up exactly the same error.
> 
> The reason I think it's something to do with this line is that I can see
> that the other links here (Fcntl & re) get created in lib/auto directory
> when I run
> make.
> 
> I tried download perl-5.8.2 (rather than 5.8.0 in the book), but get
> exactly the same error.
> 
> Any ideas?
> 
> Thanks,
> Steven
> 
> __________________________________
> Do you Yahoo!?
> Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes
> http://hotjobs.sweepstakes.yahoo.com/signingbonus

this is the first pearl pass I'm assuming. try cutting and pasting the
commands. also make sure you patched it . and that you are in the pearl
source dir as the commands given are from the source dir and not a build
dir.  

if this is the second pass try a make clean  




More information about the lfs-support mailing list