Glibc-2.3.2: Different Problems

jmh j.m.hall at cox.net
Sun Jan 11 14:03:58 PST 2004



John Cheyney wrote:
> I guess I mispoke.  Here is the whole story.
> 
> I unpacked glibc-2.3.2.tar.bz2.  This (obviously) created the
> glibc-2.3.2 directory with all of the files in it.  I then unpacked
> glibc-linuxthreads-2.3.2.tar.bz2 in the glibc-2.3.2 directory as
> ordered.  I then did the ../mkdir glibc-build and cd ../glibc-build. 
> The directory glibc-build is at the same level as glibc-2.3.2.  Then,
> from glibc-build I typed as ordered: ../glibc-2.3.2/configure etc, etc. 
> The file configured without errors, or at least it appears to have done
> so.  When I type 'make' I get the error that there is no makefile as a
> target.  The only thing in the file glibc-build is a file labeled
> config.log which doesn't have any errors.  If I go back to glibc-2.3.2
> and try 'make' I get an error that tells me I need to configure the
> file.  

Not sure if this will hel or relates but I ran into a
few errors, as I recall some were about not finding
files, when I untarred under the root user but the
compiled/make under the lfs user. If I then deleted
the source and untarred using lsf things worked fine.

Might verify who owns the working directories involved.

(My first time through so I'm still learning)

jmh




More information about the lfs-support mailing list