Hit snag when I got to patch-2.5.4

jmh j.m.hall at cox.net
Sat Jan 10 07:52:55 PST 2004


Things seemed to be going along fine until now.

I goofed when first running the configure for patch,
left of both the CPPFLAGS= and --prefix=/tools. I've tried
just rerunning using the correct cmd line:
CPPFLAGS=-D_GNU_SOURCE ./configure --prefix=/tools
but I when get to the make install point I got errors.

I get a permissions denied error creating /usr/local/man
and then one resulting from that error when attempting
to create the /usr/local/man/man1 dir.

I've also tried rm -rf /lfs/src/patch-2.5.4 to remove
the source dir (building on a single partition so
didn't worry about making $LFS), untar the package
and retry but got the same errors.

I'm a bit surprised at the path /usr/local/... Looks like
it's trying to build in the existing dir hierarchy and not
in the LFS one? Are thos paths correct? If not any ideas
where I took a wrong turn (that is, blinked while reading
this PDF and skipped a step)?

If those are correct, can I just check the permission
on /usr/loacal to make sure the lfs user has the correct
access rights?

(BTW, if you replied to my ealrier post (newbee question...)
thanks for the fast responses and suggestions!)

jmh




More information about the lfs-support mailing list