autoconf/automake/libtool trouble (bad version?)

Greg Schafer gschafer at zip.com.au
Sat Jan 10 03:39:46 PST 2004


On Sat, Jan 10, 2004 at 04:28:43PM +0500, Alexander E. Patrakov wrote:
> 2) The case with a bug - autoconf used
> 
> tar zxf gd-2.0.19.tar.gz    # (2.0.15 also has the problem)
> cd gd-2.0.19
> # Here I tried patching in GIF support, let's skip this patch.
> # After patching, autotools should regenerate the ./configure script

Bzzzt! Wrong assumption. Autotools are not smart enough yet to figure out
when to rerun libtoolize by itself. For now, the end-user must know when to
do it him/her self.

> I am not an autotools expert. How should I diagnose whether the problem
> is in LFS or on the gd author's computer?

Neither. If you patch autotools files you must realise the consequences.

I've said this in the past. Allowing the autotools to reconfigure themselves
is horrid and asking for trouble. Always do the libtoolize, aclocal, blah..
routine if you can (that is, when patching autotools files).



More information about the lfs-support mailing list